epmd fails to bind on ipaddr

Hello guys, I installed Erlang/OTP 25.1 and RabbitMQ 3.10.7 on a Windows 10 computer but I am encountering a problem.
In the RabbitMQ log there is the constant warning:

2022-09-27 12:31:37.213000+02:00 [warning] <0.388.0> epmd does not know us, re-registering rabbit at port 25672

I tried also going into the Erlang OTP installation directory, which in my case is in “C:\Program Files\Erlang OTP\erts-13.1\bin” , opening a command prompt with admin rights and running epmd, and I encounter the problem in the title:

C:\Program Files\Erlang OTP\erts-13.1\bin>epmd -d
epmd: Tue Sep 27 12:33:25 2022: epmd running - daemon = 0
epmd: Tue Sep 27 12:33:25 2022: failed to bind on ipaddr

I tried disabling the windows firewall altogether and the problem persists.
I tried disabling IPv6 in the ethernet adapter and the problem persists.
I tried editing the windows hosts file adding mappings for localhost and the computer host name, the problem still persists.

Does anybody have a clue on what could be causing the issue?

1 Like