Trying to install Erlang on Guix with ASDF


I am trying to install Erlang v26.2.3 on my newly installed Guix System box, but I am seeing some errors when trying to install with ASDF. I have installed OpenSSL and ODBC, but they are still not showing up during the install:

āžœ  src asdf install erlang 23.2.3
asdf_23.2.3 is not a kerl-managed Erlang/OTP installation
The asdf_23.2.3 build has been deleted
Extracting source code
Building Erlang/OTP 23.2.3 (asdf_23.2.3), please wait...
[packages] Unknown Linux distro guix; not checking build packages.
APPLICATIONS DISABLED (See: /home/djaouen/.asdf/plugins/erlang/kerl-home/builds/asdf_23.2.3/otp_build_23.2.3.log)
 * crypto         : No usable OpenSSL found
 * jinterface     : No Java compiler found
 * odbc           : ODBC library - link check failed
 * ssh            : No usable OpenSSL found
 * ssl            : No usable OpenSSL found

APPLICATIONS INFORMATION (See: /home/djaouen/.asdf/plugins/erlang/kerl-home/builds/asdf_23.2.3/otp_build_23.2.3.log)
 * wx             : wxWidgets was not compiled with --enable-compat28, wx will NOT be useable
 * wxWidgets don't have gl support, wx will NOT be useable
 * wxWidgets don't have wxStyledTextControl (stc.h), wx will NOT be useable
 * Can not link the wx driver, wx will NOT be useable

DOCUMENTATION INFORMATION (See: /home/djaouen/.asdf/plugins/erlang/kerl-home/builds/asdf_23.2.3/otp_build_23.2.3.log)
 * documentation  :
 *                  fop is missing.
 *                  xmllint is missing.
 *                  Using fakefop to generate placeholder PDF files.

received sigint, cleaning up%
āžœ  src
āžœ  src which openssl

Any help is greatly appreciated. Thanks!

I got a little bit further: I tried running asdf with the following options:

CC="/home/djaouen/.guix-profile/bin/gcc -I/home/djaouen/.guix-profile/include -L/home/djaouen/.guix-profile/lib" asdf install erlang 23.2.3

And now I get the following error:

/home/djaouen/.guix-profile/bin/gcc -I/home/djaouen/.guix-profile/include -L/home/djaouen/.guix-profile/lib  -Werror=undef -Werror=implicit -Werror=return-type  -fno-strict-aliasing -fno-common -g  -O3 -fno-omit-frame-pointer -I/home/djaouen/.asdf/plugins/erlang/kerl-home/builds/asdf_26.2.3/otp_src_26.2.3/erts/x86_64-pc-linux-gnu    -D_GNU_SOURCE  -DHAVE_CONFIG_H -Wall -Wstrict-prototypes -Wpointer-arith -Wmissing-prototypes -Wdeclaration-after-statement -DUSE_THREADS -D_THREAD_SAFE -D_REENTRANT -DPOSIX_THREADS -D_POSIX_THREAD_SAFE_FUNCTIONS   -DBEAMASM=1 -Ix86_64-pc-linux-gnu/opt/jit -Ibeam -Isys/unix -Isys/common -Ix86_64-pc-linux-gnu -Ipcre -Iryu -Iopenssl/include -I../include -I../include/x86_64-pc-linux-gnu -I../include/internal -I../include/internal/x86_64-pc-linux-gnu -Ibeam/jit -Ibeam/jit/x86 -c beam/erl_bif_atomics.c -o obj/x86_64-pc-linux-gnu/opt/jit/erl_bif_atomics.o
make[4]: *** [x86_64-pc-linux-gnu/Makefile:960: x86_64-pc-linux-gnu/opt/jit/asmjit/asmjit.hpp.gch] Error 1
make[4]: *** Waiting for unfinished jobs....
make[4]: Leaving directory '/home/djaouen/.asdf/plugins/erlang/kerl-home/builds/asdf_26.2.3/otp_src_26.2.3/erts/emulator'
make[3]: *** [/home/djaouen/.asdf/plugins/erlang/kerl-home/builds/asdf_26.2.3/otp_src_26.2.3/make/ opt] Error 2
make[3]: Leaving directory '/home/djaouen/.asdf/plugins/erlang/kerl-home/builds/asdf_26.2.3/otp_src_26.2.3/erts/emulator'
make[2]: *** [Makefile:45: opt] Error 2
make[2]: Leaving directory '/home/djaouen/.asdf/plugins/erlang/kerl-home/builds/asdf_26.2.3/otp_src_26.2.3/erts'
make[1]: *** [Makefile:60: jit] Error 2
make[1]: Leaving directory '/home/djaouen/.asdf/plugins/erlang/kerl-home/builds/asdf_26.2.3/otp_src_26.2.3/erts'
make: *** [Makefile:503: emulator] Error 2

OK, I fixed this by disabling wx --without-wx and installing gcc-toolchain: guix install gcc-toolchain. Thanks!

1 Like